Top head accesories not shown on the editor

Hi. Created this pill aura as top head category, it does not reflect on the editor.
Uploaded .gltf file. Is there anything I shoud change?

432 tris, 1 material , 2 textures

1 Like

Perhaps incorrectly exported from Blender? :man_shrugging:

1 Like

When I got the same issue, usually it’s because of skinning.

and also check your export settings. be sure that you select the model and click the “selected objects” option


1 Like

Thank you so much. I will follow this steps.

If you use Windows, try to open the exported Model with the built-in 3D Viewer or the Babylon Sandbox viewer so make a simple check. It sometimes happened to me, that I actually exported an empty model.

1 Like

right, select model and armature and then export from blender

1 Like

you always need to link the model to bones in order to see it’s position in the environment

1 Like

Thanks. It’s working on the Viewer.

Yes, both selected and not working.

It’s parented, but not visible on DCL editor.

Hmm…tried. still not working

did you check the normals of the model? (182.8 KB)

Hmm, it could be that your object is out of scale or you have used a wrong armature from an example file.

I’ve uploaded a small example Sandbox, including the Blender file and the exported GLB of it that works in any case. You can upload the included GLB file to your current editor scene first to see if it looks like in the screenshot.

To check if your model has the right size try this:

  • in Blender, delete the red cube and the green sphere from my example

  • import your own GLB model

  • if the scale of your model doesn’t match the size of my armature:

    • in Object Mode select your model
    • set “Origin to Geometry” if necessary
    • resize your model (it could be that 0.01 must be set to see it, Factor 100)
    • reposition the model if necessary
  • in Object Mode select your model

  • press Alt+P and select “Clear and Keep Transformation”

  • delete your Armature, keep mine

  • in Object Mode select your model again, hold Shift and select my Armature

  • press CTRL+P and parent it to the armature with automated weights

  • check and correct the Weighting

  • export and upload again

If its too complex or confusing you can upload your GLB file here and I can fix it for you.

1 Like

@metatiger you have right, sometimes it’s just the wrong armature!
I use always this one (107.2 KB)


Thank you so much for this!! I’ll follow your steps, if not working I’ll comeback. appreciated.

Thanks!! I’ll make sure it’s this one.

Yes!!! Thank you soooo much!! Our team was using the armature from DCL doc. page, with Avatar_head_end. Your file and iacob’s file doen’t have that attached.
Plus, we found out that tophead does parent to bone but no armature mordifier setting, no weight on it.
Thank you again!

1 Like

Now I have problem running "see in world " option…No collectible wearable visible.