Wearable not visible in world

Good morning,
I uploaded a wearable today and tested it in editor … it was ok and I can see it properly.
When I tried to view it in world, I can see it in the backpack and choose it… but it’s invisible in world.
Also, the thumbnail is not showing any photo.
Please help.

Screenshot of the issue
I can see the item on the left… but nothing appears on the character on the right.

check your wearables scale in your 3d Editor (blender)
It might need to be reset to 1


checked it mate… as you can see I’m able to see the wearable in editor…
Sorry about the mislocation of some items but it’s not finalized yet.

try having a look to see if there is any extra bones in the hands and delete them

I think this could be the problem, I had this before too and my object scale was way off 1,0 and I didn’t realize it as the editor still shows it. As far as I remember you can solve it in Object Mode with the Object selected:

Object > Apply > All Transforms or you use RMB > Parent > Clear and Keep Transformation.

The Object should then have a scale of 1,0 and can then re-parented to the armature (but the weightings must be checked and set again).

try to flip the normals

@ShadyAlaa was this the solution by any chance please? As I currently have the same problem with accessories showing in the builder but not in world. Personally tried this solution but it did not work for me :confused: