Tried to publish a wearable on polygon and transaction has not been approved for 2 days

Can someone please explain what I can do to get the transaction approved? I’ve asked for help on discord and got too many replies. Some were even asking me for my private keys which is a red flag to me. Appreciate the help here given I wouldn’t want to accidently waste 500 mana on another transaction and both gets approved, thanks (:

1 Like

Hey Mods @nico @sam ,
would it be an admin or something to contact about this issue?
It’s super strange that the publishing transaction is taking longer than a few minutes. I worked on this collection and hoping to help out but I think it might be a @collections glitch.

Any support or recommendation as who to contact about this would be good considering the Mana has been transferred to the @dao already.

1 Like

Thanks Michi. The mana hasn’t been transferred to the dao yet though I’m a bit concerned if I try to publish the wearable again and possibly might get charged twice! Appreciate your help here (:

This has been resolved, thanks guys!