Cannot deploy scene on rented LAND


I’ve just tried the new rental feature and rented a parcel for 30 days. For some reason I am unable to deploy a scene to this LAND now. Please note attached screenshot. Permissions are granted, MetaMask is unlocked, but the Sign&Deploy button is grayed out. The console shows me an error “MetaMask - RPC error: execution reverted”. If I try to deploy the same scene on a LAND for which I was given operator rights manually (not through the rental feature), this error does not show up and I can proceed. I couldn’t find any related topics. What am I doing wrong? :wink:

Thanks for your help.



Hey! Do you have the latest version of the CLI? Can you try to update it using npm install -g decentraland@latest then try to deploy again?

Hey @HPrivakos thanks for the reply. I updated it, but still the same issue.

I’ve rented another LAND with a different account now and am facing the same issue there too. LANDs I own or operate are no problem. For LANDs I rented, I can’t hit the Sign button. Can anyone confirm they have successfully deployed a scene to a rented LAND via CLI?

I’ve now tried to deploy a scene from Awesome Repository. Same issue. Sorry for pushing this topic. But if this is a general issue it kind of renders the whole new rental feature useless… Can anyone confirm they have successfully deployed a scene to a rented LAND via CLI?

i JUST succeeded. Downloaded the DCL extension for vscode, opened the publish page in my browser, logged in with metamask via walletconnect and I had a split second to click on the sign and deploy button before it got grayed out :-

I think you have to do this immediately after logging in with your wallet, it might not work if you are already logged in.

Hey @42meta, @Plasius, thank you for reporting this. There was an issue with the deployment dapp that would fail to deploy to lands if they were owned by a smart contract, and the smart contract didn’t implement a particular interface (which was the case for rented land). This issue has been patched in the deployment dapp, and new versions of the CLI and Editor have been released to include the fix (CLI version 3.15.0 and Editor version 1.1.0 to be precise). Thank you for reporting :pray:t2:.