Collection 'Ubiq Cyberpunk Armor' created by Intern is ready for review!

Ubiq Cyberpunk Armor

View entire collection


Cyberpunk Armor LowerBody

Cyberpunk Armor UpperBody


Thanks again to Aaron @ Cryptanthropy for sponsoring the creation of the armor set! Here is a Front and Back view of the Armor in world along with a quick video. Please let us know if anything is wrong with the models and we’ll fix them ASAP.

[Youtube Link]

1 Like

Found a mistake where Upper Body Wearable hides Feet. We’ll fix that soon!

oops, my bad. Fixed and updated.

1 Like

This is really cool! There’s a small issue with the hips, there should be a ring of vertices around them, it’s in the same place on all wearables so different items can be combined seamlessly.

There’s also a little clipping between the hands and some of the lower body wearables.

1 Like

Thanks Kat for the feedback, we’ll look into adjusting the models and keep you up to date


I believe these errors are fixed now. Builder was giving me issues uploading so I hope it all worked out. Took a few hours…

1 Like

Please let us know if there’s any further adjustments you’d like us to make as well!

Matrix looking Armor set


I love that movie series! I’m glad it gives you those Matrix vibes lol



Editor seems to have deleted our male representation, I have uploaded many times but it seems to still not be showing on the main page yet it is confirmed.

Not sure what you see on your end.

Awesome collection! You can include the other representation by going to your collection, then click on the item row.
Then click on the three dots menu to add the other model.
Thank you!

1 Like

I have added the other representation so many times now it doesn’t save in this screen nor the edit window.

It shows as uploaded but upon refresh it disappears. How do I fix this.

Look here and see how many times I have tried in the last day.

As you can see here it uploads and you can wear it. The properties panel on the right is glitching out and keeps disappearing and reappearing. When you can stop if for just a second for a screenshot you get this error in this screen too.

As you can see the properties window acting up and now the male with full representation too.

Shows as uploaded.
seems right…
Click back to marketplace and then back to collections and nothing is saved…

Let us Pray to the DCL Editor Gods :pray: :pleading_face:

@Kat @vrglitch

Would it be possible if the DAO comittee allowed us to reupload the wearable set?

Given the unforeseeable circumstances of the editor servers glitching out and preventing us from importing the male representations. Maybe if we were able to reupload the models fresh it will finally upload correctly?

We’ve tried everything we can think of on our side but it will not go through and throws an error exception.

edit: If you prefer to wait a bit and allow any server patches to come through, that’s totally fine too.

Hey @Cryptanthropy !. The team is working on this. Once its fixed you will be able to update both representations with no issues. Thanks for your patience

1 Like

Thanks for the Update, Sounds good :+1:

Hey @Cryptanthropy , please try again. It should be working fine now.

Unfortunately it is still broken. The error messages are gone for the most part but the editor will only allow one representation to be saved at a time. If I use male then female disappears and vice versa. I have tried both methods to add representation, in the edit screen and from the main window by adding representation. I reloaded browser to no success and now the editor is saying my item is to big but it is only 695kb and my icon pic is less than 320kb so I am not sure what is happening here.




Getting closer but I feel there is still a glitch somewhere.