Tags in asset.json in ZIP package not recognized?

Hi there,

I’m struggling with a small issue where I don’t know whether it works as designed or if I make a mistake.
It’s about uploading a new asset, packaged as a ZIP file, to builder.decentraland.org to create a new item. The ZIP contains the asset.json which I’ve filled even with some tags. However, after the upload my tags does not appear in the UI while other settings does. Not sure if this is an intended behavior or if I have some errors in the syntax of the file? I’ve used a template for the asset.json from the Wearables resource here: Wearable Resources - Google Drive

This is how my JSON looks like:

    "name": "Test T-Shirt",
    "i18n": {
      "en": "Test T-Shirt",
      "de": "Test T-Shirt"
    "tags": [
    "category": "upper_body",
    "replaces": [],
    "hides": [],
    "main": [
            "type": "BaseMale",
            "model": "M_uBody_PoloTShirtTest.glb",
            "overrideReplaces": [],
            "overrideHides": []
        {"type": "BaseMale", "model": "M_uBody_PoloTShirtTest.glb"}
    "rarity": "rare",
    "description": "Test T-Shirt"

But after uploading it, it looks like it even does not recognize the body shape, which I guess should be given by the type? I’ve to select it:

Then, once created, the tags are empty:

Is this issue on my side?


I’m not much of a coder, but I wonder if this would work.

"tags": [
  "tshirt, police, male, shirt"],

Thanks, but unfortunately, this doesn’t work either. :man_shrugging:

AFAIK, there is no need to use the .JSON files, this is from the time when there was no Wearable Editor yet. :grin:

You can customize all these settings in the Builder itself.

Try importing only the .glb file into the Builder.