Collection 'Sway - AwedJob x Tang' created by tangpoko is ready for review!

Sway - AwedJob x Tang

View entire collection


Sway This Way

Sway That Way

I will check collection now

1 Like

@tangpoko collection approved!

1 Like

Thank you so much! Come and dance with me!


@theankou Thank you for approving this but we are still having the issue referenced at the link below, where “Sway That Way” emote (m_Swat.glb) does not play when triggered, all it does is freeze the other emote that is current playing. This issue persists with clearing cahce in the browser, it also exists in the client. See video posted by AwedJob below.

you are right, @tangpoko, looks like i tested the one emote twice and though that both emotes works, but looks like something wrong with “Sway That Way” glb

Do you have any suggestions on how we can get this fixed? It doesnt seem to be an issue with the file…

i’m not sure, but maybe something was wrong with export settings? or armature have some unnecessary components thats was exported too and may cause issues (builder will show animation, but in-world it will not work because armatures are not the same)

make sure that exported glb contain only armature files and avatar shape, without any IK components

Hi @theankou, I’m the one who animated both emotes. Could you explain what you mean by this:

According to Isa’s YT video on “Creating an emote”, the directions are:
“You only want the armature and the animation to be exported.”

I have turned off the mesh visibility, the ground reference, and the animation area. The image below shows what is visible in the YT video:
Screenshot from 2023-08-26 18-32-02
and this is what is visible in the Blender file for the “Sway That Way” glb:

The video instructs “under ‘limit to’, select ‘visible objects’.” This check box is in the same location for Blender 3.6 as it is in the Blender version Isa used 11 months ago.

However, the “Export Deformation Bones Only” check box is not under “Animation” → “Animation” in 3.6.
Instead it is located under “Data” → “Armature”.

There is also an extra “Use Rest Position Armature” check box that is checked but as far as I know is not in the earlier Blender version. Is this what you are referring to by “IK components?”:


Success! I went back a few versions of the emote until I could export one that worked. Then I animated that file to the point of completion. This is a synchronized emote so I was careful to select the armature rig that I know worked with the other emote.
Peek 2023-08-26 22-04

1 Like

Thank you @AwedJob! Hi @theankou - I have updated the GLB, can we push the update? Thank you!


collection re-approved!

1 Like

Thank you so much! This has been a challenge but very rewarding.

HI @theankou - Scott and I were finally able to test these two emote in world together, and we see we need to make som aadjustments, We shoud have these ready for a re-approval later today! Just giving you a heads up - thank you !


Ok @theankou - we have made some adjustments and we are ready to update when you are! Thank you!


@tangpoko collection re-approved!